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SAAR: Spatial Analysisusing ArcGlSengineand R

I ntroduction

This lab demonstrates the functionalities of SAAgng an empirical dataset. It follows a generatigpa
data analysis process, ranging from simple mapprgloratory spatial data analysis, and confirmator
spatial data analysis, to an uncertainty explonaticthe analyses and data.

The empirical data are obtained from the 2010-ZB/k4year American Community Survey (ACS) data for
Texas counties. Specifically, this lab mainly prasea series of spatial data analyses using theass of
median house valué\alue) for the 254 counties in Texas. Two additionaiafales, the unemployment rate
(unemploy) and median year in which a structure was byeéar(), are used as covariates in the context of
regression.

Setting up the lab
» Lab data and installation file for the software available on T:\ywchun\SAAR.
» Make a working folder and get data files in tbilér

» The software is already installed on your locakchnne. Start SAAR by clicking the icn@

Task 1. Simple mapping and creating a layout

1-1. Drawing a chor opleth map
» We will draw a simple choropleth map of unemploy.
=

1. Select File» Open Documer . Browse to your own folder and opéaiue of Home.mxd”.

2. Click ¥ 1o open the "Add shapefile" dialog. Breate your own folder and add X_Cnt_2014.shp”.
3. Right-click onTX_Cnt_2014 and choose "Symbology". You should see a “Symhdldglog window.
4. Click on the tab called “Choropleth”.

5. We need to specify the field (i.e., attributed want to display. Pull down the box right to "Valkield"
and selecUnemploy.
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4 TX_Cnt_2014 Symbology =
Simple | Choropleth | Proportional symbols I Graduated symbaols
Value Field: Unemploy -
Classification Method: Natural Breaks + MNumber of Class: 5 =
Symbol Color Ramps: | Color ramp algorthm: CIE Lsb -
Outline Line Width: (0.5 % Outline Line Color: -
Symbol Range Label
4 I I 0.00-3.60 0.00 - 3.60
[ ]/361-580 361-560
[ 561-800 5.61-8.00
I (z.01-11.20 801-1120
« I 1121-1760 1121-17.60
4 1 b
L ooy | [ Concel |

— The classification was automatically done. We also define the number of classes and a classdicat
method. In addition, we can determine the breaktdor each class manually by clicking the rangebox.

6. Change “Symbol Color Ramps” Blue Light to Dark located at the top of the color scheme list. Then,
click Apply to draw a choropleth map. Close the ri&plogy” dialog window.

1-2. Export the map layout asan imagefile
» Now, we will export the map as an image file.
1. From the menu bar, select LayeutOpen Layout View.

2. We will work on only the'X_Cnt_2014 layer. Turn off the display dfivalue by checking off the boxes
before their layer names.

3. Select Insert* Legend and North Arrow to add a legend and a remrbw on the map.

4. Choose Insert* Scale Bar and a window will pop up. Select “DigisiUnits” asMiles and set the
“Number of Division” a2.

34 Propeties
Division Units:  Miles -

Mumber of Divisions: [P

Insert | | Cancel
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5. Using navigation tools (e.g., zoom = and & full,extent(;3 ), change the location and scale of

the map. Also, using the select element k | , ghahe location and size of the map elements (i.e.,
legend, scale bar, and north arrow).

6. Select File» Export to open an Export window. Check “Clip OutpuGraphics Extent”, and then, click
Export.

24 Bxport Map
Resolution: {150 =l "dpi
7] Clip Dutput to Graphics Extent

| Bpot | | Cancel |

7. Change “Save as type” to “Tiff files (*.tif)” nal type a proper name of the map.

8. Close the layout view by clicking the close bul@ .

Task 2. Exploratory data analysis (EDA)

m SAAR contains EDA tools with the support of dynarinking and brushing techniques among statistical
graphs and a layer map in a map view. EDA toolgsttpnot only generic graphics such as histogram,
boxplot, and scatter plot, but also violin and duercomparison plots.

2-1. Drawing a histogram and scatter plots

» In here, we will explore the distribution b¥alue, and a relationship betweéralue and the selected
covariatesunemploy andyear.

1. Now, we will mainly work on thélvalue layer. Drag thédvalue layer to the top of the Table of Content.
Then, turn off the display afX_Cnt_2014 by checking off the boxes.

2. Click Explore— Histogram. You can see a “Histogram” window.

3. Set a target layer to thbvalue layer, and a field tbvalue. Then, click the “Create Histogram” button.



04/06/2018

4 Histogram @
Select a Tanget Layer:
Hvalue -
Figld:
bvalue) \
Mumber of Bins: 13 =
| Create Histogram | | Cancel |

4. Explore the numerical distribution lofalue, and doNOT close the histogram.
5. Select Explore~> Scatterplot. Choose a target layer asHkalue layer.

6. Set the “Field 1 (X-Axis)” toyear and “Field 2 (Y-Axis)” tohvalue. Then, click the “Create Scatterplot”
button.

4 Scatterplot @

Select a Target Layer:

Hvalue -
Field 1 (¥-fuis):

Year -
Field 2 ('r-fuis):

hvalue -

| Create Scatterplot | ‘ Cancel ‘

7. In the same way, create a scatter pldivafue andunemploy to see a relationship between them.

8. Explore the relationship betwelevalue and its covariates. DHOT close the scatter plots.

2-2. Dynamic linking and brushing

» Now, the relationship among the three variables loa explored further with dynamic linking and
brushing.

1. Arrange the size and positon of three statispilcais and the map view to see all windows simmdtausly.

2. Click an individual bin in the histogram. Thgwou will see the corresponding counties in thetecatots
and the map view.
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— In this dynamic linking and brushing, differeni@mosymbols are used for an input (in cyan) anddar
sources (in red) to distinguish them easily froroheather.

3. Now, on the scatter plot b¥alue andunemploy, click a left mouse button and drag to choosetgoirhen,
explore the corresponding counties in differentdews.

(74 Scatter Plot of Hvalue =S =

hvalue = -2,444.343 * Unemploy + 111.775.722

2591454
2430671

186583 - =~ b
.

hvalue

1309171 4 .

.
e TAY A N
748334 o .,.:.‘-‘,j..k: .’r}'i‘.b-'-_-fﬁ o

18755
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4. A map view can also be used as an input of dymanking and brushing. Click “Brushing and Linigh

tool @ on the toolbar in the main window. Then, selkegions that you want to see in the histograch an
the scatter plots.

— We will use dynamic linking and brushing with @éifént graphs in the next task.

5. Close all graphs. If you have selected countigke map view, click the “Clear Selected Featutesl
™ on the toolbar.

Task 3. Exploratory spatial data analysis (ESDA) and spatial autocorrelation

m SAAR provides a set of global and local spatigbaarrelation measures, and ESDA tools, including
Conditioned Choropleth maps, a connectivity hisdtogrand map, a Moran scatter plot, and spatial
correlogram.
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» In here, we will explore both global and local tsleaautocorrelation fohvalue.

1. Select Analysis» Global Spatial Autocorrelation.

2. Set a target layer to thtvalue layer, and a field tbvalue.

Select a Target Layer:
Hvalue

Field:
hvalue

Spatial Weight Matrix

Select Spatial Autocomelation Measure:
Moran Coefficient

Inference Assumption:

MNarmality

(4 Spatial Autocorrelation @

Contiguity (Queen) E]

QK Cancel

-

-

-

— The default for the definition of a spatial weigtmatrix is a queen definition for polygon contiges.

When you click the butto.[_:] , You can also use a rdeknition and higher order spatial weights. In
addition, SAAR can load a spatial weights matronirGeoDa files (i.e., *.gal and *.gwt).

— For point contiguities, the default for the defiion is a Delaunay triangle, which can be clippgdab
polygon. You can also use a fixed distance andatast neighbors definitions in the advanced spatial

weights matrix window.

Polygon Point
o) fremAdvSWM a2l frnAdvSWM (=22
Defintion:  Contiguity (Queen) - Defintion:  Delaunay tiangulation
Contiguity Order: 1= 100.00 =
Clip by pohygons: Clip
Load SWM from GeoDafies: [ .. | Load SWM from GeoDa fles: | .. |
[ Ay | [ Cancel | [ oy | [ Concel |

3. Select a spatial autocorrelation measuid asan Coefficient, and an inference assumptioriNas mality.

— This tool also supports a Geary ratio and a ramziinon assumption.
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4. Click OK, then you can see a “Summary” window. 54 Local SAM =

. . . . Sel T: :
5. Now, we will explore local spatial autocorretati Select Analysis— el

Hvalue -
Local Spatial Autocorrelation (univariate). Thenjlacal SAM” window | Ffei:

W|” pop up_ hvalue -
Select Spatial Autocomelation Measure:
6. Set a target layer to thbvalue layer, and a field tbvalue. Local Moran -
Spatial Weight Matrix -
7. Select a spatial autocorrelation measuieags! Moran. Cortiguty (Queen) L]
Multiple Test Adjustment:
. . . . Borfermoni comection -
8. Set a multiple test adjustmentBonferroni correction. e ot
ave nesuls
“ ” H Confid I |: 0.050 :
9. Check on the “Add a map” box, and then Click OK. oriidenes e
Types Figld Name

10. The results of local spatial autocorrelatioa save in the target shap ::aﬂsdﬂcrdd . "Z
file. Based on the results, a local Moran Coeffitimap will be drawn.

-Value Pr
lIJ:L.'-\.G fla
11. Right-click on alLocal Moran of Hvalue layer and choose "Ope
Attribute Table". You can see an attribute of tager from the window. In| & agdamep

there, you can also find the results of the lopatial autocorrelation.

QK Cancel

12. Close the attribute table by clicking the (:Ibsuatonné| .

3-2. Moran scatter plot and spatial correlogram

» Now, we will explore spatial autocorrelation fuethusing a Moran scatter plot and spatial correlogr
with dynamic linking and brushing.

2. Click Explore— Moran Scatterplot. You can see a “Moran Scattet” plindow.

B Maran Scatter Plot @
Select a Target Layer:
Hvalue -
Field:
hvalue -

| Use Standardized Varable

Spatial Weight Matrix -
Contiguity (Queen)

QK Cancel
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3. Set a target layer to thévalue layer, and a field tcwalue. Check on the box of “Use Standardized
Variable”.

4. Click OK, then you will see the result of the Mo scatter plot.

— The slope of a regression line represents a glblmehn Coefficient value when using standardized
variables.

5. Click a left mouse button and drag to selechfsoiThen, you can see a corresponding countytand i
neighbors. DANOT close the Moran scatter plot.

6. Now, select Analysis> Spatial Correlogram.
7. Again, set a target layer to tHealue layer, and a field tbvalue.

8. Select a spatial autocorrelation measure asl Maian, and the maximum lag ordermad hen, click OK.
The spatial correlogram will appear in a left panel

Select a Target Layer:
Hvalue -

Select Spatial Autocomelation Measure:
Local Moran Coefficient -

Variable:

hvalue -

Spatial Weight Matrixc

Contiguity (Queen) _
Mandimum lag order: b =
| Box Plot Wiolin Plot

| ok | | Cancel |

— A spatial correlogram tool can help to exploretishautocorrelation at a particular spatial lagl ais
trend across spatial lags.

9. In the same way to the previous Moran scattet, ghoose points in the spatial correlogram to see
corresponding counties and their neighbor on the view and the Moran scatter plot.

10. Explore the spatial autocorrelation in différgpatial lags using dynamic linking and brushing.

11. Close both plots by clicking the close bu“g|

12. Right-click on d.ocal Moran of Hvalue layer and choose "Remove layer" to remove thierd&pm the
table of contents.
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Task 4. Data transfor mations and regression analysis

m SAAR supports various regression analysis toolduding simple linear regression, generalizeddine
model (GLM), various spatial regressions, and Maeagenvector spatial filtering (MESF) for lineardan
GLM specifications. In addition, SAAR furnishes eXBCox transformation tool to convert an input abie
to one that better mimics a normal distributioe.(ibell-shaped curve).

4-1. Box-Cox transformation
1. Select Data» Data Transformation, and then a “Box-Cox Transftion” window will pop up.

2. Set a target layer to tikvalue layer, and a field thvalue. A normal quantile-quantile (Q-Q) plot and a
histogram will be drawn based on the select field.

— This tool applies Box-Cox transformation for aestéd variable using the following equation. If the
selected variable contains O (zero) values, an “@ddma” box will be automatically checked on.

i+nt-1
A —_—
yi(): 7 if 1 #0,

In(y; +y) ifA1=0

{4 Box-Cox Transformation <l

Input
Select a Target Layer:
ue

299145+ 200

Variable
hvalue - 243067
| Add Gamma 2 150

BoxCox Transformation Py

186989

hvalue

130911

50
748334

a 100000 200000 300000
50000 150000 250000

Normal QGuantile hvalue

tr_hvalue 18755

Bow-Cox Transformation |

3. Click the “Box-Cox Transformation” buttc| . Thean estimated parameter of
“Lambda” (1) will be shown. Also, the normal Q-Q plot and thistogram will be updated based on the
transformed variable.

— The parameters for the transformation are estunayehe maximum likelihood estimation.

4. See the normal Q-Q plot, the histogram, andadkelt of Shapiro-Wilk test to evaluate the transfation
result.
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| Show Original GQ Plot |

5. Click the “Show Original Q-Q plot buttot
transformed variable with that of the original \ednlie.

to impare the distribution of the

6. Now, move the slide b.__ 8 under the Lambda patemte interactively see the impact
of the parameter on the transformation result.

7. Click the "Box-Cox Transformation” buttc  BoCox Transfomation |

agdmget the optimal parameters.

8. In the “Save Result” group box , set the “Fidldme” totr_hvalue. Then, click the “Save” button

lil to store the transformed variable as an additifiedd. We will use this field for regression
analyses.

4-2. Linear regression
1. Click Regressior- Linear Regression. You can see the “Linear Regme’ssiindow.

2. Choose a target layer as thealue layer, and a dependent variablgrasivalue, which is derived from
the previous step.

:;:] Linear Regression @
3. Set mependent variablesunemploy andyear by click the | & o Torget Layer
= i ) Hvalue v
button or double-click on a field name. Dependert Variable:
tr_hvalue -

— If you check on the “Show Diagnostics plots”, fidiagnostic

plots (e.g., plots of residuals against fitted ealusquare root of == 'TJdEpe”lde”* Vanables
. . . - nemplay
absolute residuals against fitted values, a Noi@&) plot, and | |rvauem 5] |Year
residuals against leverages) will be appear. Pnhwme_ —
Edu

4. In the “Residual analysis” group box, check oa tCalculate | |
Moran Coefficient for Residuals” box. Set the splatveight
matrix toContiguity (Queen). Show Diagnostics Flots

Residual analysis

| Caleulate Moran Coefficient for Residuals

5. Also, in the “Save” box, check on the “Save esgion
Spatial Weight Matrix

residuals” box to draw the map of the linear regi@sresiduals. Cortiquty (Qusen) =
Save

6. Click the “Run” bUtt0n| il | , and then, th V| Save regression residuals

“Linear Regression Summary” window will pop up. ke the Types Field Name

linear regression result. Residuals iin_resi

7. Close the *“Linear Regression Summary” and “Ling
| Run | | Cancel

Regression” windows by clicking the close but“g|

10
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8. Right-click on theHvalue layer and choose "Symbology". Choose the valué &slin_resi.

9. Change the number of classe$ saind symbol color ramps t@lueto Red”.

10. Click the hea. 20! of label lists. Then, you daa ‘Decimal Places” window. Change
the value tal.
Decimal Places @
MNumber of decimal places:
]
[ ok ][ Cance |

— For further adjustment, You can manually changeréimge of classes by clicking the range list box.

11. Click the “Apply” button Apply , and close the “Symdbgy” window. Explore the spatial
distribution of the linear regression residuals.

4-3. Spatial regression
1. Click Regressior» Spatial Autoregression. Then, the “Spatial Autoesgion” window.
2. Choose a target layer as tthealue layer, and a dependent variabldrafivalue.

3. In the same way to the previous step, assiggmploy andyear to independent variables.

Al Spatial Autoregression @
Select a Target Layer: Corfiguration
Hvalue hd Madel
Dependert Variable: @ SAR (Spatial Emor) AR (Spatial Lag)
tr_hvalue -
CAR SMA Durbin
Spatial Weight Matrix -
Contiguity {Queen) Jacobian Computation
@ Eigen Matrix Matrze_J
Fields Independent Varables LU Chebyshev Marte Caro
hvalue Unemploy
hvalue_m Year
hvalue_se Fo
hh (.
iggome ILI /| Save regression residuals
u I
tr_hvalue <
it Types Field Name
Residuals spr_resi
Run | | Cancsl

11
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4. In the *“Configuration” group box, we will use nuiltaneous autoregressive (SAR) model
© SAR(Spatial Emor) it the exact eigenvalue meth® Egen  for Jacobianpdation.

— For further information, refer tohttps://www.rdocumentation.org/packages/spdep/oassd.7-
4/topics/do_ldet

5. In the “Save” box, check on the “Save regressisiduals” box to explore the spatial distributadrspatial
regression residuals.

Run

6. Click the “Run” buttor,| | , and then, the “Spatflitoregressive Model Summary”

window will pop up. Evaluate the result.

— You might see a warning message. Exact Jacobrapuition using eigenvalue might require relatively
long time for the calculation depending on a perfance of your computer.

7. Close the summary and spatial autoregressiodoms.
8. Right-click on theHvalue layer and select "Symbology".

9. Now, using thespr_resi field, draw a residual map. You can refer the mes step (8-11 in 4.2 Linear
regression).

10. Explore the spatial distribution of the spategression residuals.

4-4. Moran eigenvector spatial filtering (ESF)

1. Select Regression Eigenvector Spatial Filtering. Then, the “EigenweSpatial Filtering” window will
appear.

2. Choose a target layer as thealue layer, a dependent variabletashvalue, and dependent variables as
unemploy andyear.

3. We will use a linear regression specificationMiESF. Choose the “Family” dsinear (Gaussian).
4. In the “Candidate Eigenvector Selection”, set@xfault selection (positive only).”

— For further information for the candidate selectroethod, you can refer Chun Y, Griffith D A, Lee M
and Sinha P 2016 Eigenvector selection with stepvégression techniques to construct eigenvectirasp
filters. Journal of Geographical Systems 18: 67—85.

6. In the “Save” box, check on the “Save residaad spatial filter” box to explore a residual dlsiition
and selected spatial filter.

12
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H Eigenvector Spatial Filtering B

Select a Tanget Layer:
Spatial Weight Matrix:
Hvalue

Contiguity (Queen
Famity: auity { ) I—/

Linear (Gaussian) - Candidate Eigenvector Selection

Dependent Variable: @ Default selection (Positive only)

tr_hvalue -

Eigenvalues over the principal =  |0.25
Positive Only
Figlds Independent Varables
£ Show coefficients of selected eigenvectors
hvalue Unemploy
hvalue_m Year Save
hvalue_se
hh ] | Save residuals and spatial fiter
income >
Edu — Types Field Name
tr_hvalue < " .
lin_resi Residuals esf_resi
spr_resi Spatial Fiter sfitter
Run | | Cancel

Run

7. Click the “Run” buttor.| | , and then, the “ESF Lan&egression Summary” window will

pop up. Evaluate the result.

— Again, MESF need to calculate eigenvalues ancheggetors. If the number of observation become large
the time needed for the estimation increases.

8. Close the summary and spatial autoregressiodoms.
8. Right-click on theHvalue layer and select "Symbology".
9. Again, using thesf_resi field, draw a residual map, and explore the map.

10. Now, we will draw the map of the estimated spdilter. Open the “Symbology” window from the
Hvalue layer.

11. Choose the value field Ba_resi, Then, change the number of classe8 &md symbol color ramps to
“Green to Red”.

12. Click the “Apply” button Apply , and close the “Synibgy” window. Explore the spatially
structured random effect from the regression model.

Task 5. Geovisualization for spatial data uncertainty

13
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m SAAR provides toolsets to explore uncertaintypatgal data and SDA output in two different congext
geovisualization, and map classification. In this, lwe will use uncertainty geovisualization tatdseloped
based on bivariate mapping technique.

5-1. Thecoloring propertiesto proportional symbols

1. Click Uncertainty— Visualization (Static}» Proportional Symbol with Color Combination. Théime
“Coloring properties to proportional symbols” windavill pop up.

H Coloring properties to proportional symbaols @

Layer: Propartional Symbaol
Hvalue M Min Symbol Size: |3 =
Value Field:
hvalue - Symbol Color: -
Uncerainty Field: ) ) —~
hvalue_se - Line width: 0.1 =
V| Create New Layer Line Color: -
MNew Layer Name:
CPPS_value Methods:

Value -
| Ppply | | Cancel |

2. Choose a target layer as tHealue layer. Set a value and uncertainty fieldshealue andhvalue_se,
respectively.

3. Check on the “Create New Layer” box, and typewa layer name toCPPS_Value'.

4. Set the “Min Symbol Size” 18, and the “Methods” t&value.

Apply

5. Click the “Apply” button , and close the window.

6. Explore the median house value map, and exathéeeliability of the value.

- The End-
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